CVE-2026-0933: Cloudflare wrangler · Wrangler affected by OS Command Injection in `wrangler pages deploy`
Affects cloudflare-wranglerSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 4.121.0 soon.
Data as of 30 Oct 2026, 07:30 UTC
- Patch
- Available – fixed in 4.121.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade cloudflare-wrangler to 4.121.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewcloudflare-wranglerpkg:brew/cloudflare-wranglerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
**Summary** A command injection vulnerability (CWE-78) has been found to exist in the `wrangler pages deploy` command. The issue occurs because the `--commit-hash` parameter is passed directly to a shell command without proper validation or sanitization, allowing an attacker with control of `--commit-hash` to execute arbitrary commands on the system running Wrangler. **Root cause** The `commitHash` variable, derived from user input via the `--commit-hash` CLI argument, is interpolated directly into a shell command using template literals (e.g., ``execSync(`git show -s --format=%B ${commitHash}`)``). Shell metacharacters are interpreted by the shell, enabling command execution. **Impact** This vulnerability is generally hard to exploit, as it requires `--commit-hash` to be attacker controlled. The vulnerability primarily affects CI/CD environments where `wrangler pages deploy` is used in automated pipelines and the `--commit-hash` parameter is populated from external, potentially untrusted sources. An attacker could exploit this to: - Run any shell command. - Exfiltrate environment variables. - Compromise the CI runner to install backdoors or modify build artifacts. **Mitigation** - Wrangler v4 users are requested to upgrade to Wrangler v4.59.1 or higher. - Wrangler v3 users are requested to upgrade to Wrangler v3.114.17 or higher. - Users on Wrangler v2 (EOL) should upgrade to a supported major version. **Credits** Disclosed responsibly by kny4hacker.
References
- github.com/cloudflare/workers-sdk/security/advisories/GHSA-36p8-mvp6-cv38 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-0933 (opens in a new tab)
- github.com/cloudflare/workers-sdk/commit/99b1f328a9afe181b49f1114ed47f15f6d25f0be (opens in a new tab)
- github.com/cloudflare/workers-sdk (opens in a new tab)
- github.com/cloudflare/workers-sdk/releases/tag/wrangler%403.114.17 (opens in a new tab)
- github.com/cloudflare/workers-sdk/releases/tag/wrangler%404.59.1 (opens in a new tab)