CVE-2026-0933: Cloudflare Wrangler · Improper Input Validation
Affects Cloudflare WranglerSource CVE Database V5
Not known to be exploited · CVSS 7.7 High.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| CloudflareWrangler | Affected
| Fixed in– |
GitHubWranglerpkg:github/WranglerOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should take immediate and specific actions to mitigate CVE-2026-0933 beyond generic patching advice: 1) Upgrade all instances of Cloudflare Wrangler to at least v4.59.1 or v3.114.17, avoiding use of EOL versions like v2. 2) Audit CI/CD pipelines to identify any usage of the `wrangler pages deploy` command, especially where the `--commit-hash` parameter is dynamically set from external or user-controlled sources. 3) Implement strict input validation and sanitization on any inputs feeding into the `--commit-hash` parameter to prevent injection of shell metacharacters. 4) Restrict permissions of CI/CD runners and build agents to minimize impact if compromised, employing least privilege principles. 5) Monitor CI/CD logs and environment variables for unusual command executions or anomalies indicative of exploitation attempts. 6) Use containerization or isolated build environments to contain potential damage from command injection. 7) Establish alerting mechanisms for unexpected changes in build artifacts or deployment processes. 8) Educate DevOps teams about the risks of unsanitized inputs in deployment commands and enforce secure coding and pipeline configuration practices. 9) Consider integrating security scanning tools that detect unsafe shell command usage in scripts and automation. 10) Coordinate with Cloudflare support for any additional guidance or updates related to this vulnerability.
Description
**Summary** A command injection vulnerability (CWE-78) has been found to exist in the `wrangler pages deploy` command. The issue occurs because the `--commit-hash` parameter is passed directly to a shell command without proper validation or sanitization, allowing an attacker with control of `--commit-hash` to execute arbitrary commands on the system running Wrangler. **Root cause** The `commitHash` variable, derived from user input via the `--commit-hash` CLI argument, is interpolated directly into a shell command using template literals (e.g., ``execSync(`git show -s --format=%B ${commitHash}`)``). Shell metacharacters are interpreted by the shell, enabling command execution. **Impact** This vulnerability is generally hard to exploit, as it requires `--commit-hash` to be attacker controlled. The vulnerability primarily affects CI/CD environments where `wrangler pages deploy` is used in automated pipelines and the `--commit-hash` parameter is populated from external, potentially untrusted sources. An attacker could exploit this to: - Run any shell command. - Exfiltrate environment variables. - Compromise the CI runner to install backdoors or modify build artifacts. **Mitigation** - Wrangler v4 users are requested to upgrade to Wrangler v4.59.1 or higher. - Wrangler v3 users are requested to upgrade to Wrangler v3.114.17 or higher. - Users on Wrangler v2 (EOL) should upgrade to a supported major version. **Credits** Disclosed responsibly by kny4hacker.