Skip to main content
CVE-2026-59954VulnerabilityPublished

Com.ctrip.framework.apollo:apollo: Apollo ConfigService access key authentication bypass via appId parsing and

Affects com.ctrip.framework.apollo:apolloSource GCVE Database

0

Not known to be exploited · CVSS 7.5 High · fixed in 2.5.2 : patch com.ctrip.framework.apollo:apollo soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Mavencom.ctrip.framework.apollo:apolloAffected
  • <=2.0.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apollo ConfigService to version 2.5.2 or later, where this vulnerability is fixed. No other mitigations are indicated or required by the vendor advisory. Patch status is confirmed fixed in 2.5.2.

Description

Apollo ConfigService versions prior to 2.5.2 have an improper input validation vulnerability that may allow unauthorized access to configuration data when AccessKey or management key authentication is enabled. The issue arises because ConfigService accepts non-canonical appId variants during authentication, which downstream request handling resolves to protected applications. This includes variants with accent-insensitive collations or trailing spaces on the /configs and /configfiles endpoints. The vulnerability is fixed in version 2.5.2.

References

Community reviews

Loading reviews…