Com.ctrip.framework.apollo:apollo: Apollo ConfigService access key authentication bypass via raw config file appId
Affects com.ctrip.framework.apollo:apolloSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 2.5.2 : patch com.ctrip.framework.apollo:apollo soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavencom.ctrip.framework.apollo:apollo | Affected– | Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apollo ConfigService to version 2.5.2 or later, where this improper input validation issue is fixed. No other mitigations are indicated. Patch status is confirmed by the vendor advisory stating the fix is in 2.5.2.
Description
Apollo ConfigService versions prior to 2.5.2 contain an improper input validation vulnerability that may allow unauthorized access to raw configuration data. The issue arises because requests to the /configfiles/raw/{appId}/{clusterName}/{namespace} endpoint are incorrectly parsed for authentication, causing the service to verify the wrong appId and potentially bypass signature verification. This vulnerability is fixed in version 2.5.2.