Skip to main content
VulnerabilityPublished Updated

CVE-2026-59946: Composer · Path traversal in package bin field lets dependencies chmod arbitrary host files

Affects composerSource GCVE Database

0

Not known to be exploited : upgrade to 2.10.2 or 2.2.29 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.10.2, 2.2.29

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade composer to 2.10.2 or 2.2.29.

Affected software

ProductAffectedFixed in
Bitnamicomposerpkg:bitnami/composerOther threatsAffected
  • >=1.0.0 <2.2.29
  • >=2.3.0 <2.10.2
Fixed in
  • 2.2.29
  • 2.10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a Composer package bin entry containing .. path segments can resolve outside the package install directory and cause Composer's binary installation flow to chmod an existing host file to a world-readable and world-executable mode during composer install, update, or require. This issue is fixed in versions 2.2.29 and 2.10.2.

References

Community reviews

Loading reviews…