Skip to main content
CVE-2026-40261VulnerabilityPublished Updated

BIT-composer-2026-40261: Composer has Command Injection via Malicious Perforce Reference

Affects composerSource GCVE Database

0

Not known to be exploited : upgrade to 2.9.6 or 2.2.27 soon.

Data as of 26 Oct 2026, 12:29 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.6% chance of exploitation in 30 days – higher than 76% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.9.6, 2.2.27

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade composer to 2.9.6 or 2.2.27.

Affected software

ProductAffectedFixed in
Bitnamicomposerpkg:bitnami/composerOther threatsAffected
  • >=1.0.0 <2.2.27
  • >=2.3.0 <2.9.6
Fixed in
  • 2.2.27
  • 2.9.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Composer versions 2.2.27 and 2.9.6. Users should upgrade to these versions or later. If immediate upgrade is not possible, users can mitigate risk by avoiding installing dependencies from source using the --prefer-dist option or setting preferred-install to dist in Composer configuration. Additionally, only trusted Composer repositories should be used to prevent malicious package metadata injection.

Description

Composer, a PHP dependency manager, contains a command injection vulnerability in versions 1.0 through 2.2.26 and 2.3 through 2.9.5. The vulnerability exists in the Perforce::syncCodeBase() and Perforce::generateP4Command() methods, which improperly escape user-supplied parameters, allowing arbitrary command injection. This can be exploited via malicious package metadata from compromised or malicious Composer repositories when installing or updating dependencies from source. The issue is fixed in Composer 2.2.27 and 2.9.6. Workarounds include avoiding source installs by using --prefer-dist or trusted repositories.

References

Community reviews

Loading reviews…