Composer, a PHP dependency manager, contains a command injection vulnerability in versions 1.0 through 2.2.26 and 2.3 through 2.9.5. The vulnerability exists in the Perforce::syncCodeBase() and Perforce::generateP4Command() methods, which improperly escape user-supplied parameters, allowing arbitrary command injection. This can be exploited via malicious package metadata from compromised or malicious Composer repositories when installing or updating dependencies from source. The issue is fixed in Composer 2.2.27 and 2.9.6. Workarounds include avoiding source installs by using --prefer-dist or trusted repositories.