Skip to main content
CVE-2026-121945VulnerabilityPublished

CoopCycle coopcycle-web before 6.20.1 contains a broken access control vulnerability that allows any courier to read

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121945· High 7.2

Not known to be exploited · CVSS 7.2 High : upgrade to 6.20.1 soon.

Data as of 4 Nov 2026, 16:43 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.2
CNA (VulnCheck)CVSS 3.17.6
Patch
Available – fixed in 6.20.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade coopcycle-web to 6.20.1.

Affected software

ProductAffectedFixed in
CoopCyclecoopcycle-webAffected
  • <6.20.1
Fixed in
  • 6.20.1
GitHubcoopcycle-webpkg:github/coopcycle-webOther threatsAffected
  • <6.20.1
Fixed in
  • 6.20.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in version 6.20.1 of CoopCycle coopcycle-web. Users should upgrade to version 6.20.1 or later to remediate this broken access control vulnerability. No other mitigation or temporary workaround is indicated in the provided data.

Description

CoopCycle coopcycle-web versions before 6.20.1 have a broken access control vulnerability that allows any courier user to read and modify all incident records. The flaw arises because incident operations only verify the ROLE_COURIER role without further authorization checks. Attackers can enumerate incident IDs and use the PUT /api/incidents/{id}/action endpoint to alter orders and tasks belonging to other stores, including repricing, canceling, or rescheduling them.

References

Community reviews

Loading reviews…