Skip to main content
CVE-2026-110684VulnerabilityPublished Updated

Cpanel::JSON::XS versions from 3.0202 before 4.80 for Perl leak memory and retain overloaded objects when encoding

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-110684· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 4.80 soon.

Data as of 29 Oct 2026, 20:14 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.18.1
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.80
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Cpanel-JSON-XS (Perl module) to 4.80.

Affected software

ProductAffectedFixed in
Cpanel-JSON-XSAffected
  • >=3.0202 <4.80
Fixed in
  • 4.80
CPANCpanel-JSON-XSpkg:cpan/Cpanel-JSON-XSOther threatsAffected
  • >=3.0202 <4.80
Fixed in
  • 4.80

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 4.80 or later of Cpanel::JSON::XS addresses this memory leak. Users should upgrade to version 4.80 or newer to remediate this issue. No other mitigation or temporary workaround is indicated.

Description

Cpanel::JSON::XS versions from 3.0202 up to but not including 4.80 for Perl have a memory leak vulnerability. The encode_stringify function retains references to overloaded objects and their data without releasing them, causing unbounded memory growth when encoding such values repeatedly.

References

Community reviews

Loading reviews…