CVE-2026-110680: Cpanel::JSON::XS versions from 4.20 before 4.80 for Perl write out of bounds when a tied or shared
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.80 soon.
Data as of 30 Oct 2026, 14:03 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 4.80
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Cpanel-JSON-XS (Perl module) to 4.80.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cpanel-JSON-XS | Affected
| Fixed in
|
CPANCpanel-JSON-XSpkg:cpan/Cpanel-JSON-XSOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid using vulnerable versions or avoid encoding tied or shared hashes with canonical encoding if possible.
Description
Cpanel::JSON::XS versions from 4.20 up to but not including 4.80 for Perl contain a vulnerability where encoding a tied or shared hash with canonical encoding can cause out-of-bounds writes. This occurs because the encoder uses a fixed-size or heap array sized from a first pass count, but a second pass that exceeds this capacity writes beyond allocated memory, leading to memory corruption and potential process crashes.