Skip to main content
VulnerabilityPublished Updated

CVE-2026-110675: Cpanel::JSON::XS versions from 4.33 before 4.80 for Perl accept malformed UTF-8 in bare hash keys

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-110675· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 4.80 soon.

Data as of 29 Oct 2026, 20:16 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.18.1
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.80
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Cpanel-JSON-XS (Perl module) to 4.80.

Affected software

ProductAffectedFixed in
Cpanel-JSON-XSAffected
  • >=4.33 <4.80
Fixed in
  • 4.80
CPANCpanel-JSON-XSpkg:cpan/Cpanel-JSON-XSOther threatsAffected
  • >=4.33 <4.80
Fixed in
  • 4.80

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid enabling allow_barekey with utf8 in decode_hv or sanitize input to prevent malformed UTF-8 in bare keys.

Description

Cpanel::JSON::XS versions from 4.33 up to but not including 4.80 for Perl improperly accept malformed UTF-8 in bare hash keys when using allow_barekey in decode_hv. This causes malformed UTF-8, control bytes, and backslashes to be stored without validation, leading to errors in later operations such as case conversion or re-encoding. The vulnerability can cause denial of service due to application crashes triggered by malformed UTF-8 errors.

References

Community reviews

Loading reviews…