Skip to main content
CVE-2025-66570VulnerabilityPublished Updated

SUSE · cpp-httplib-devel-0.28.0-1.1 on GA media

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2025-66570· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade SUSE cpp-httplib to 0.27.0 as a priority.

Data as of 1 Nov 2026, 12:28 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.27.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade yhirose/cpp-httplib to 0.27.0.

Affected software

ProductAffectedFixed in
GitHubyhirose/cpp-httplibpkg:github/yhirose/cpp-httplibOther threatsAffected
  • <0.27.0
Fixed in
  • 0.27.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update to the cpp-httplib-devel-0.28.0-1.1 package on openSUSE Tumbleweed to apply the security fixes. Since this package version contains the fixes, no additional mitigation steps are indicated.

Description

Multiple security issues were addressed in the cpp-httplib-devel-0.28.0-1.1 package included in the GA media of openSUSE Tumbleweed. The update fixes vulnerabilities affecting this package version. No specific details about the nature of the vulnerabilities or affected versions are provided.

References

Community reviews

Loading reviews…