Skip to main content
CVE-2025-66570VulnerabilityPublished

CVE-2025-66570: yhirose cpp-httplib · Authentication Bypass by Spoofing

Affects yhirose cpp-httplibSource CVE Database V5

0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 0.27.0 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.27.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade yhirose/cpp-httplib to 0.27.0.

Affected software

ProductAffectedFixed in
GitHubyhirose/cpp-httplibpkg:github/yhirose/cpp-httplibOther threatsAffected
  • <0.27.0
Fixed in
  • 0.27.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately identify any use of cpp-httplib versions prior to 0.27.0 in their software stacks, including embedded systems, internal tools, and third-party applications. The primary mitigation is to upgrade to cpp-httplib version 0.27.0 or later, where the vulnerability is fixed by proper header handling. If upgrading is not immediately feasible, organizations should implement strict input validation and filtering at the network perimeter or application firewall to block or sanitize suspicious HTTP headers named REMOTE_ADDR, REMOTE_PORT, LOCAL_ADDR, and LOCAL_PORT. Application-level logging and authorization code should be reviewed to ensure they do not trust client-supplied headers for critical decisions. Employing additional authentication factors beyond IP-based checks can reduce risk. Monitoring logs for anomalous header values or repeated attempts to inject spoofed headers can aid early detection. Finally, organizations should conduct security testing and code reviews to verify no other header injection or spoofing vulnerabilities exist in their HTTP handling components.

Description

CVE-2025-66570 is a critical authentication bypass vulnerability in versions of the yhirose cpp-httplib library prior to 0.27.0. The flaw allows attacker-controlled HTTP headers (REMOTE_ADDR, REMOTE_PORT, LOCAL_ADDR, LOCAL_PORT) to be injected and influence server-side metadata, logging, and authorization decisions due to header shadowing. Because the library processes client headers before adding its own internal metadata headers with the same names, downstream code that retrieves header values uses attacker-supplied data, enabling IP spoofing, log poisoning, and authorization bypass without authentication or user interaction. This vulnerability affects any server using vulnerable cpp-httplib versions and can lead to full compromise of confidentiality and integrity. The issue is fixed in version 0.27.0. European organizations using cpp-httplib in web services should urgently update to mitigate risk.

References

Community reviews

Loading reviews…