Craft CMS 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 contains a blind SQL injection vulnerability because the
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 4.18.9 soon.
Data as of 6 Nov 2026, 16:50 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.1 |
- Patch
- Available – fixed in 4.18.9, 5.11.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade cms to 4.18.9; cms to 5.11.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
| craftcmscms | Affected
| Fixed in
|
AI-suggested
A fix is available in Craft CMS versions 4.18.9 and later for the 4.x branch and 5.11.2 and later for the 5.x branch. Users should upgrade to these versions to remediate the vulnerability. No other mitigation steps are indicated.
Description
Craft CMS versions 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 contain a blind SQL injection vulnerability. This occurs because the getNext() and getPrev() methods expose sandboxed template functionality that improperly passes arbitrary criteria arrays to Craft::configure() without filtering out SQL-related properties like orderBy and where. Authenticated control panel users can exploit this by supplying crafted elementIds values to execute conditional SQL queries under the Craft database account.