Craft CMS from 5.8.17 before 5.11.2 contains a privilege escalation vulnerability because getOwners() applies caller
Source GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 5.11.2 soon.
Data as of 6 Nov 2026, 17:02 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.8 |
- Patch
- Available – fixed in 5.11.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade cms to 5.11.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
AI-suggested
A fix is available in Craft CMS version 5.11.2. Users should upgrade to version 5.11.2 or later to remediate this vulnerability. No other mitigation or temporary workaround is indicated.
Description
Craft CMS versions from 5.8.17 up to but not including 5.11.2 contain a privilege escalation vulnerability. This flaw arises because the getOwners() function applies caller criteria without properly cleansing the query configuration. As a result, authenticated control panel users can exploit this to invoke attacker-selected static PHP callables, which can promote any account to administrator privileges.