Skip to main content
VulnerabilityPublished

craftcms/cms · Craft CMS: Stored XSS

Affects craftcms/cmsSource GCVE Database

0

CVSS 5.1 Medium : upgrade to 5.10.8 when convenient.

Data as of 7 Aug 2026, 07:01 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.10.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

What to do

Upgrade craftcms/cms to 5.10.8.

Affected software

ProductAffectedFixed in
Packagistcraftcms/cmsAffected
  • >=5.0.0-RC1 <5.10.8
Fixed in
  • 5.10.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should apply the official fix provided by the vendor to ensure the draftName is properly HTML-encoded before rendering. Until patched, restrict draft creation permissions to trusted users and avoid exposing draft chips/cards to higher-privileged users if possible. Check the vendor advisory for the official patch and remediation instructions.

Description

A stored cross-site scripting (XSS) vulnerability exists in Craft CMS control panel where an element's draft name is rendered without proper HTML encoding. A low-privilege user who can create drafts can inject JavaScript payloads into the draft name, which execute in the browsers of higher-privileged users viewing the draft's chip or card. This allows the attacker to execute arbitrary JavaScript in the victim's authenticated control panel session, potentially taking over the control panel by performing admin-only actions via the victim's session.

References

Community reviews

Loading reviews…