Skip to main content
VulnerabilityPublished Updated

craftcms/cms · Duplicate Advisory: Craft CMS Vulnerable to Stored XSS in Settings Names and Field Options

Affects craftcms/cmsSource GCVE Database

0

CVSS 4.8 Medium · fixed in 4.17.0 : update craftcms/cms when convenient.

Data as of 7 Aug 2026, 07:01 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.17.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

What to do

Affected software

ProductAffectedFixed in
Packagistcraftcms/cmsAffected
  • >=5.0.0-RC1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Craft CMS to version 4.17.0-beta.1 or later for the 4.x branch, or to version 5.9.0-beta.1 or later for the 5.x branch, where the stored XSS vulnerabilities have been fixed. No other mitigations are indicated by the advisory.

Description

Craft CMS versions 4.x (from 4.0.0-RC1 up to but not including 4.17.0-beta.1) and 5.x (from 5.0.0-RC1 up to but not including 5.9.0-beta.1) contain multiple stored cross-site scripting (XSS) vulnerabilities. These vulnerabilities arise because settings names and field option labels are rendered without proper sanitization, allowing an authenticated administrator with allowAdminChanges enabled to inject malicious JavaScript payloads. This can lead to arbitrary script execution in other users' control-panel sessions. The issue is fixed in versions 4.17.0-beta.1 and 5.9.0-beta.1.

References

Community reviews

Loading reviews…