Craft CMS versions 4.x (from 4.0.0-RC1 up to but not including 4.17.0-beta.1) and 5.x (from 5.0.0-RC1 up to but not including 5.9.0-beta.1) contain multiple stored cross-site scripting (XSS) vulnerabilities. These vulnerabilities arise because settings names and field option labels are rendered without proper sanitization, allowing an authenticated administrator with allowAdminChanges enabled to inject malicious JavaScript payloads. This can lead to arbitrary script execution in other users' control-panel sessions. The issue is fixed in versions 4.17.0-beta.1 and 5.9.0-beta.1.