CVE-2026-116695: Crass · Incorrect tokenization of bad URLs enables CSS sanitizer bypass
Affects crassSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.0.8 when convenient.
Data as of 28 Oct 2026, 23:14 UTC
- Patch
- Available – fixed in 1.0.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade crass to 1.0.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemscrass | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Crass version 1.0.8. Users of Sanitize, Loofah, rails-html-sanitizer, or any other library that uses Crass for CSS sanitization should upgrade to Crass 1.0.8 or later. There are no practical workarounds other than upgrading. Rejecting CSS input containing the sequence "\\" could block the trigger but may cause false positives and reject legitimate CSS.
Description
Crass, a CSS tokenizer, incorrectly handles bad URL tokens when a closing parenthesis follows an escaped backslash, causing it to consume more input than browsers do. This flaw can cause CSS sanitizers that rely on Crass to mistakenly allow malicious CSS declarations, style rules, or at-rules such as @import to pass through. The vulnerability affects CSS sanitizers like Sanitize, Loofah, and rails-html-sanitizer, enabling attackers to smuggle CSS that can be used for UI redress, loading attacker-controlled resources, or CSS-based data exfiltration. The issue does not enable script execution in modern browsers. The vulnerability is fixed in Crass version 1.0.8.
References
- github.com/rgrove/crass/security/advisories/GHSA-pq4g-8rxf-4g29 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-116695 (opens in a new tab)
- github.com/rgrove/crass/commit/689fc45c632fdf3803b2f4e844ffc9cca3b08f34 (opens in a new tab)
- github.com/rgrove/crass (opens in a new tab)
- github.com/rgrove/crass/releases/tag/v1.0.8 (opens in a new tab)
- github.com/rubysec/ruby-advisory-db/blob/master/gems/crass/GHSA-pq4g-8rxf-4g29.yml (opens in a new tab)