Skip to main content
VulnerabilityPublished

CVE-2026-56259: Crawl4AI versions before 0.8.8 have credential exfiltration vulnerabilities in their Docker API server

Affects crawl4aiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 0.8.8 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade unclecode/crawl4ai to 0.8.8.

Affected software

ProductAffectedFixed in
GitHubunclecode/crawl4aipkg:github/unclecode/crawl4aiOther threatsAffected
  • <0.8.8
Fixed in
  • 0.8.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the affected endpoints and avoid exposing the Docker API server publicly. Monitor for unusual API call redirections and environment variable access patterns.

Description

Crawl4AI versions before 0.8.8 have credential exfiltration vulnerabilities in their Docker API server. Attackers can exploit unauthenticated endpoints (/md, /llm, /llm/job) by manipulating the base_url parameter and setting api_token to environment variable references, allowing them to read arbitrary environment variables. This can lead to exfiltration of sensitive data such as provider API keys and JWT SECRET_KEY, enabling authentication bypass.

References

Community reviews

Loading reviews…