CVE-2026-119118: unclecode crawl4ai · Improper Certificate Validation
Affects unclecode crawl4aiSource CVE Database V5
Not known to be exploited · CVSS 8.3 High : upgrade to 0.9.5 soon.
Data as of 29 Oct 2026, 16:36 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 0.9.5
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade unclecode crawl4ai to 0.9.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| unclecodecrawl4ai | Affected
| Fixed in
|
PyPIcrawl4aipkg:pypi/crawl4aiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Crawl4AI to version 0.9.5 or later, where this vulnerability is fixed. The fix removes the insecure Chromium launch flags and restores proper certificate validation and sandboxing. No other mitigation is required once the update is applied.
Description
Crawl4AI versions before 0.9.5 have an improper certificate validation vulnerability due to Chromium launching with --ignore-certificate-errors and a hard-coded --no-sandbox override. This allows network attackers performing man-in-the-middle or DNS attacks to serve forged content to the crawler and intercept sensitive data such as cookies and headers.