Skip to main content
VulnerabilityPublished Updated

CVE-2026-102266: Critical · fence-agents security update

Affects fence-agents-aliyunSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-102266· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 4.10.0-110.el9_8.8 soon.

Data as of 4 Nov 2026, 20:35 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.10.0-110.el9_8.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the AlmaLinux to 4.10.0-110.el9_8.8.

Affected software

ProductAffectedFixed in
AlmaLinux 9fence-agents-aliyunAffected
  • <4.10.0-110.el9_8.8
Fixed in
  • 4.10.0-110.el9_8.8
AlmaLinux 9fence-agents-allAffected
  • <4.10.0-110.el9_8.8
Fixed in
  • 4.10.0-110.el9_8.8
AlmaLinux 9fence-agents-amt-wsAffected
  • <4.10.0-110.el9_8.8
Fixed in
  • 4.10.0-110.el9_8.8
AlmaLinux 9fence-agents-apcAffected
  • <4.10.0-110.el9_8.8
Fixed in
  • 4.10.0-110.el9_8.8
AlmaLinux 9fence-agents-apc-snmpAffected
  • <4.10.0-110.el9_8.8
Fixed in
  • 4.10.0-110.el9_8.8
AlmaLinux 9fence-agents-awsAffected
  • <4.10.0-110.el9_8.8
Fixed in
  • 4.10.0-110.el9_8.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied promptly. Upgrade fence-agents to version 4.10.0-110.el9_8.8 or later to remediate these vulnerabilities. Refer to the Red Hat advisory RHSA-2026:94500 for detailed update instructions. No additional mitigation is required beyond applying the official patch.

Description

The fence-agents package, used for remote power management in cluster environments, contains multiple critical authentication bypass vulnerabilities in its pyjwt dependency. These flaws include acceptance of empty HMAC keys, improper public key validation, and token forgery via Unicode byte-order mark mishandling. These issues could allow attackers to bypass authentication mechanisms. A security update fixing these vulnerabilities is available in fence-agents version 4.10.0-110.el9_8.8.

References

Community reviews

Loading reviews…