Skip to main content
VulnerabilityPublished Updated

CVE-2026-102266: Critical · fence-agents security update

Affects fence-agents-aliyunSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-102266· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 4.16.0-21.el10_2.7 soon.

Data as of 4 Nov 2026, 20:35 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.16.0-21.el10_2.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the AlmaLinux to 4.16.0-21.el10_2.7.

Affected software

ProductAffectedFixed in
AlmaLinux 10fence-agents-aliyunAffected
  • <4.16.0-21.el10_2.7
Fixed in
  • 4.16.0-21.el10_2.7
AlmaLinux 10fence-agents-allAffected
  • <4.16.0-21.el10_2.7
Fixed in
  • 4.16.0-21.el10_2.7
AlmaLinux 10fence-agents-amt-wsAffected
  • <4.16.0-21.el10_2.7
Fixed in
  • 4.16.0-21.el10_2.7
AlmaLinux 10fence-agents-apcAffected
  • <4.16.0-21.el10_2.7
Fixed in
  • 4.16.0-21.el10_2.7
AlmaLinux 10fence-agents-apc-snmpAffected
  • <4.16.0-21.el10_2.7
Fixed in
  • 4.16.0-21.el10_2.7
AlmaLinux 10fence-agents-awsAffected
  • <4.16.0-21.el10_2.7
Fixed in
  • 4.16.0-21.el10_2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that fixes these vulnerabilities in fence-agents. Users should upgrade to version 4.16.0-21.el10_2.7 or later as provided by the Red Hat advisory RHSA-2026:94501. Applying this update will remediate the authentication bypass issues. No additional mitigation steps are indicated by the vendor.

Description

The fence-agents package, used for remote power management in cluster environments, contains multiple critical authentication bypass vulnerabilities in its dependency pyjwt. These flaws include acceptance of empty HMAC keys, improper public key validation, and token forgery via Unicode byte-order mark handling. These issues could allow attackers to bypass authentication mechanisms related to cluster node management.

References

Community reviews

Loading reviews…