Skip to main content
VulnerabilityPublished Updated

CVE-2026-42215: Cruft · GitPython has Command Injection via Git options bypass

Affects cruftSource GCVE Database

0
Authoritative record:CVE-2026-42215· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 2.16.0_8 soon.

Data as of 26 Oct 2026, 17:43 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.16.0_8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade cruft to 2.16.0_8.

Affected software

ProductAffectedFixed in
Homebrewcruftpkg:brew/cruftOther threatsAffected
  • >=2.12.0 <2.16.0_8
Fixed in
  • 2.16.0_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 2.16.0_8 that fixes this command injection vulnerability by properly validating underscore-form keyword arguments. Users should upgrade to version 2.16.0_8 or later to remediate this issue. Until then, avoid passing untrusted input to the affected API methods or explicitly set 'allow_unsafe_options' to True only if safe. No other mitigations are indicated by the vendor advisory.

Description

GitPython versions from 2.12.0 up to but not including 2.16.0_8 contain a command injection vulnerability due to improper validation of Python keyword arguments that map to unsafe Git command options. Specifically, the use of underscore-form kwargs like 'upload_pack' and 'receive_pack' bypasses the safety checks that block dangerous Git options, allowing arbitrary command execution when attacker-controlled input is passed to certain GitPython API methods.

References

Community reviews

Loading reviews…