Crypt::Age versions before 0.004 for Perl allow CPU exhaustion via an unbounded number of recipient stanzas, each
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.004 soon.
Data as of 30 Oct 2026, 17:02 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 0.004
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Crypt-Age (Perl module) to 0.004.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Crypt-Age | Affected
| Fixed in
|
CPANCrypt-Agepkg:cpan/Crypt-AgeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Crypt::Age version 0.004 or later. Users should upgrade to version 0.004 or newer to mitigate this vulnerability. Until patched, avoid decrypting files from untrusted sources or implement rate limiting and resource usage monitoring to mitigate denial of service risks.
Description
Crypt::Age versions before 0.004 for Perl contain a vulnerability that allows an attacker to cause CPU exhaustion by submitting a file with an unbounded number of recipient stanzas. Each stanza triggers expensive cryptographic operations during decryption, leading to denial of service.