Skip to main content
VulnerabilityPublished Updated

CVE-2026-39892: Cryptography vulnerable to buffer overflow if non-contiguous buffers were passed to APIs

Affects cryptographySource GCVE Database

0
Compare
Authoritative record:CVE-2026-39892· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 46.0.7 when convenient.

Data as of 4 Nov 2026, 04:28 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (GitHub_M)CVSS 4.06.9
ADP (redhat-SADP)CVSS 3.17.3
Patch
Available – fixed in 46.0.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade cryptography to 46.0.7.

Affected software

ProductAffectedFixed in
PyPIcryptographyAffected
  • >=45.0.0 <46.0.7
Fixed in
  • 46.0.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in cryptography version 46.0.7. Users should upgrade to version 46.0.7 or later to remediate this vulnerability. Red Hat has issued multiple security advisories with updated container images that include the fix. Applying these updates promptly will mitigate the risk. No additional mitigation steps are indicated by the vendor advisory.

Description

A buffer overflow vulnerability exists in the cryptography library when non-contiguous Python buffers are passed to certain APIs such as Hash.update(). This flaw affects versions from 45.0.0 up to but not including 46.0.7 and can cause reading past the end of the buffer in Python versions greater than 3.11. The vulnerability has a critical severity with a CVSS score of 9.8. A patch is available in version 46.0.7.

References

Community reviews

Loading reviews…