A buffer overflow vulnerability exists in the cryptography library when non-contiguous Python buffers are passed to certain APIs such as Hash.update(). This flaw affects versions from 45.0.0 up to but not including 46.0.7 and can cause reading past the end of the buffer in Python versions greater than 3.11. The vulnerability has a critical severity with a CVSS score of 9.8. A patch is available in version 46.0.7.