CVE-2026-86409: curl vulnerabilities
Affects curlSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 8.20.0-2ubuntu11.1 soon.
Data as of 31 Oct 2026, 04:23 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 8.1 |
|---|
- Patch
- Available – fixed in 8.20.0-2ubuntu11.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu curl package to 8.20.0-2ubuntu11.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10curlpkg:deb/ubuntu/curl?arch=source&distro=stonkingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by updating curl to version 8.20.0-2ubuntu11.1 or later on Ubuntu 26.10 systems. The vendor advisory confirms that this update addresses the listed vulnerabilities. Applying the official update will mitigate the risks associated with these issues.
Description
Multiple security vulnerabilities were identified in curl, including issues that could lead to information disclosure, denial of service, arbitrary code execution, and man-in-the-middle attacks. These vulnerabilities affect various curl features such as WebSocket handling, AWS SigV4 authentication, SSH host verification, cookie handling, HTTP proxy authentication, HSTS processing, IMAP command injection, FTP wildcard matching, TFTP transfer direction validation, file overwrite protection, MIME structure processing, and HTTP/2 upload handling. The vulnerabilities were fixed in Ubuntu 26.10 package version 8.20.0-2ubuntu11.1.
References
- ubuntu.com/security/notices/USN-8927-2 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86409 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86410 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86412 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86414 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87862 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87863 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87864 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87865 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92386 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92387 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92388 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92389 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92390 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92391 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92392 (opens in a new tab)
- ubuntu.com/security/CVE-2026-94266 (opens in a new tab)
- ubuntu.com/security/CVE-2026-107928 (opens in a new tab)
- ubuntu.com/security/CVE-2026-107929 (opens in a new tab)