Skip to main content
CVE-2026-92387VulnerabilityPublished Updated

curl · By permanently omitting the final control-response line, a malicious FTP, IMAP, POP3, or SMTP server can exploit

Affects curlSource GCVE Database

0
Compare
Authoritative record:CVE-2026-92387· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in 8.20.0-2ubuntu11.1 : patch curl soon.

Data as of 31 Oct 2026, 04:22 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.18.1
Patch
Available – fixed in 8.20.0-2ubuntu11.1, 8.18.0-1ubuntu2.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu curl to 8.20.0-2ubuntu11.1 (package) or 8.18.0-1ubuntu2.8 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10curlpkg:deb/ubuntu/curl?arch=source&distro=stonkingOther threatsAffected
  • <8.20.0-2ubuntu11.1
Fixed in
  • 8.20.0-2ubuntu11.1
Ubuntu 26.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=resoluteOther threatsAffected
  • <8.18.0-1ubuntu2.8
Fixed in
  • 8.18.0-1ubuntu2.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to Ubuntu package versions 8.20.0-2ubuntu11.1 or 8.18.0-1ubuntu2.8 or later. Users should update their curl packages to these fixed versions to remediate the vulnerability. No additional mitigation is indicated by the vendor advisory.

Description

A vulnerability in libcurl allows a malicious FTP, IMAP, POP3, or SMTP server to bypass the configured transfer timeout by permanently omitting the final control-response line. This flaw causes libcurl to indefinitely block all concurrent transfers bound to the same multi-handle. The issue affects specific Ubuntu package versions of curl and has been assigned CVE-2026-92387 with a high severity rating and a CVSS score of 8.1. Fixes are available in Ubuntu package versions 8.20.0-2ubuntu11.1 and 8.18.0-1ubuntu2.8.

References

Community reviews

Loading reviews…