CVE-2022-40674: n/a
Source CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.4.9 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2022
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade libexpat/libexpat to 2.4.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublibexpat/libexpatpkg:github/libexpat/libexpatOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately identify all systems and applications using libexpat versions prior to 2.4.9. This includes scanning software inventories, dependencies, and embedded devices. The primary mitigation is to upgrade libexpat to version 2.4.9 or later where the vulnerability is fixed. If upgrading is not immediately feasible, organizations should apply virtual patching via web application firewalls or intrusion prevention systems to detect and block suspicious XML payloads that could trigger the vulnerability. Network segmentation and strict input validation on XML data sources can reduce exposure. Monitoring for anomalous application crashes or memory errors related to XML parsing is recommended to detect potential exploitation attempts. Security teams should also review vendor advisories for products bundling libexpat and apply vendor patches promptly. Given the high severity, organizations should prioritize patching in critical environments and consider threat hunting for signs of exploitation. Finally, maintaining up-to-date backups and incident response plans will help mitigate impact if exploitation occurs.
Description
libexpat before 2.4.9 has a use-after-free in the doContent function in xmlparse.c.
References
- github.com/libexpat/libexpat/pull/629 (opens in a new tab)
- github.com/libexpat/libexpat/pull/640 (opens in a new tab)
- debian.org/security/2022/dsa-5236 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2022/09/msg00029.html (opens in a new tab)
- security.gentoo.org/glsa/202209-24 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WE2ZKEPGFCZ7R6DRVH3K6RBJPT42ZBEG/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J2IGJNHFV53PYST7VQV3T4NHVYAMXA36/ (opens in a new tab)
- security.netapp.com/advisory/ntap-20221028-0008/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GSVZN3IJ6OCPSJL7AEX3ZHSHAHFOGESK/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XCGBVQQ47URGJAZWHCISHDWF6QBTV2LE/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LQB6FJAM5YQ35SF5B2MN25Y2FX56EOEZ/ (opens in a new tab)
- security.gentoo.org/glsa/202211-06 (opens in a new tab)