CVE-2023-25727: phpMyAdmin · Cross-site Scripting
Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium · fixed in 5.2.1 : update phpMyAdmin when convenient.
Data as of 26 Oct 2026, 15:59 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Affects
- phpMyAdmin before 4.9.11
- Patch
- Available – fixed in 5.2.1, 4.9.11
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Feb 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
The primary mitigation is to upgrade phpMyAdmin installations to version 4.9.11, 5.2.1, or later, where this vulnerability is patched. Organizations should audit their phpMyAdmin versions and apply updates promptly. Additionally, restrict phpMyAdmin access to trusted networks and users using network segmentation, VPNs, or IP whitelisting to reduce exposure. Implement strong authentication mechanisms, including multi-factor authentication, to limit the risk from compromised credentials. Disable or restrict the drag-and-drop SQL import feature if possible, or monitor usage closely. Employ Content Security Policy (CSP) headers to mitigate the impact of potential XSS attacks. Regularly review logs for suspicious activity related to file uploads or session anomalies. Educate administrators about the risks of uploading untrusted SQL files and encourage secure operational practices.
Description
In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.