Skip to main content
VulnerabilityPublished Updated

CVE-2023-28531: OpenSSH versions from 8.9 up to but not including 9.3 have a

Affects opensshSource CVE Database V5

0

Not known to be exploited : upgrade to 9.3 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

Severity
Medium

Rated Medium by the CNA (mitre) · No CVSS score from NVD or the CNA

EPSS
2.9% chance of exploitation in 30 days – higher than 87% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Mar 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/openssh package to 9.3.

Affected software

ProductAffectedFixed in
Debiandebian/opensshpkg:deb/debian/opensshOther threatsAffected
  • <9.3 >=8.9
Fixed in
  • 9.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenSSH to version 9.3 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

OpenSSH versions from 8.9 up to but not including 9.3 have a vulnerability in ssh-add where smartcard keys are added to ssh-agent without enforcing the intended per-hop destination constraints. This could potentially allow keys to be used in unintended contexts. The issue is fixed in OpenSSH version 9.3.

References

Community reviews

Loading reviews…