CVE-2026-35387: OpenSSH before 10.3 can use unintended ECDSA algorithms
Affects opensshSource GCVE Database
Not known to be exploited · CVSS 3.1 Low · fixed in 1:6.6p1-2ubuntu2.13+esm4 : update openssh when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1:6.6p1-2ubuntu2.13+esm4, 1:7.2p2-4ubuntu2.10+esm10, 1:7.6p1-4ubuntu0.7+esm6 +7
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10openssh-ssh1pkg:deb/ubuntu/openssh-ssh1?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSopensshpkg:deb/ubuntu/openssh?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 26.04 LTSopenssh-ssh1pkg:deb/ubuntu/openssh-ssh1?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10opensshpkg:deb/ubuntu/openssh?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10openssh-ssh1pkg:deb/ubuntu/openssh-ssh1?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSopensshpkg:deb/ubuntu/openssh?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by updating OpenSSH to the fixed versions provided by the vendor. For Ubuntu systems, updating to the patched OpenSSH packages as listed in the Ubuntu Security Notice USN-8222-1 will remediate the issue. Standard system updates will apply the necessary fixes. No additional mitigations are required beyond applying the official updates.
Description
OpenSSH versions before 10.3 have a vulnerability where listing any ECDSA algorithm in the PubkeyAcceptedAlgorithms or HostbasedAcceptedAlgorithms configuration options is misinterpreted to mean all ECDSA algorithms are accepted. This behavior can lead to the use of unintended ECDSA algorithms, contrary to administrator expectations. The issue has a low severity rating and a CVSS score of 3.1. A fix is available and included in updated OpenSSH packages distributed by Ubuntu.