Skip to main content
VulnerabilityPublished

CVE-2026-35385: openssh security update

Affects opensshSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-35385· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 8.0p1-29.el8_10 : patch openssh soon.

Data as of 27 Oct 2026, 01:25 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.0p1-29.el8_10, 0.10.3-7.29.el8_10
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 8.0p1-29.el8_10 (openssh package, openssh-askpass package, openssh-cavs package, openssh-clients package, openssh-keycat package, openssh-ldap package, openssh-server package) or 0.10.3-7.29.el8_10 (pam_ssh_agent_auth package).

Affected software

ProductAffectedFixed in
AlmaLinux 8opensshAffected
  • <8.0p1-29.el8_10
Fixed in
  • 8.0p1-29.el8_10
AlmaLinux 8openssh-askpassAffected
  • <8.0p1-29.el8_10
Fixed in
  • 8.0p1-29.el8_10
AlmaLinux 8openssh-cavsAffected
  • <8.0p1-29.el8_10
Fixed in
  • 8.0p1-29.el8_10
AlmaLinux 8openssh-clientsAffected
  • <8.0p1-29.el8_10
Fixed in
  • 8.0p1-29.el8_10
AlmaLinux 8openssh-keycatAffected
  • <8.0p1-29.el8_10
Fixed in
  • 8.0p1-29.el8_10
AlmaLinux 8openssh-ldapAffected
  • <8.0p1-29.el8_10
Fixed in
  • 8.0p1-29.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied immediately. The fixed versions are 8.0p1-29.el8_10 and 0.10.3-7.29.el8_10 or later. Refer to the Red Hat advisory RHSA-2026:13383 and the update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps.

Description

Multiple security vulnerabilities have been identified in OpenSSH, including a privilege escalation via the scp legacy protocol, security bypass through mishandling of the authorized_keys principals option, information disclosure from unintended cryptographic algorithm usage, low integrity impact from proxy-mode multiplexing sessions, and arbitrary command execution via shell metacharacters in usernames. These issues affect OpenSSH versions prior to 8.0p1-29.el8_10 and 0.10.3-7.29.el8_10. A security update addressing these vulnerabilities is available from Red Hat.

References

Community reviews

Loading reviews…