Skip to main content
VulnerabilityPublished

CVE-2026-35385: openssh security update

Affects opensshSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-35385· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 8.7p1-49.el9_7.alma.1 : patch openssh soon.

Data as of 27 Oct 2026, 01:25 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.7p1-49.el9_7.alma.1, 0.10.4-5.49.el9_7.alma.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 8.7p1-49.el9_7.alma.1 (openssh package, openssh-askpass package, openssh-clients package, openssh-keycat package, openssh-server package) or 0.10.4-5.49.el9_7.alma.1 (pam_ssh_agent_auth package).

Affected software

ProductAffectedFixed in
AlmaLinux 9opensshAffected
  • <8.7p1-49.el9_7.alma.1
Fixed in
  • 8.7p1-49.el9_7.alma.1
AlmaLinux 9openssh-askpassAffected
  • <8.7p1-49.el9_7.alma.1
Fixed in
  • 8.7p1-49.el9_7.alma.1
AlmaLinux 9openssh-clientsAffected
  • <8.7p1-49.el9_7.alma.1
Fixed in
  • 8.7p1-49.el9_7.alma.1
AlmaLinux 9openssh-keycatAffected
  • <8.7p1-49.el9_7.alma.1
Fixed in
  • 8.7p1-49.el9_7.alma.1
AlmaLinux 9openssh-serverAffected
  • <8.7p1-49.el9_7.alma.1
Fixed in
  • 8.7p1-49.el9_7.alma.1
AlmaLinux 9pam_ssh_agent_authAffected
  • <0.10.4-5.49.el9_7.alma.1
Fixed in
  • 0.10.4-5.49.el9_7.alma.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied to affected systems. The fixed versions are 8.7p1-49.el9_7.alma.1 and 0.10.4-5.49.el9_7.alma.1. Users should follow the vendor's official update instructions as detailed in the Red Hat advisory (RHSA-2026:13381). No additional mitigation steps are indicated beyond applying the official patches.

Description

Multiple security vulnerabilities have been identified in OpenSSH, including privilege escalation via the scp legacy protocol, security bypass due to mishandling of authorized_keys principals option, information disclosure from unintended cryptographic algorithm usage, low integrity impact from unconfirmed proxy-mode multiplexing sessions, and arbitrary command execution through shell metacharacters in usernames. These issues affect various versions of OpenSSH prior to the fixed releases 8.7p1-49.el9_7.alma.1 and 0.10.4-5.49.el9_7.alma.1. A security update addressing these vulnerabilities is available and recommended for affected systems.

References

Community reviews

Loading reviews…