Skip to main content
CVE-2026-35414VulnerabilityPublished Updated

OpenSSH before 10.3 mishandles the authorized_keys principals option in uncommon scenarios involving a principals list

Affects opensshSource GCVE Database

0
Compare
Authoritative record:CVE-2026-35414· Medium 4.2

Not known to be exploited · CVSS 4.2 Medium · fixed in 1:6.6p1-2ubuntu2.13+esm4 : update openssh when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1:6.6p1-2ubuntu2.13+esm4, 1:7.2p2-4ubuntu2.10+esm9, 1:7.6p1-4ubuntu0.7+esm6 +5
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10openssh-ssh1pkg:deb/ubuntu/openssh-ssh1?arch=source&distro=stonkingOther threatsAffected
  • =1:7.5p1-18
  • =1:7.5p1-18ubuntu1
  • =1:7.5p1-18ubuntu2
Fixed in–
Ubuntu 26.04 LTSopensshpkg:deb/ubuntu/openssh?arch=source&distro=resoluteOther threatsAffected
  • <1:10.2p1-2ubuntu3.2
Fixed in
  • 1:10.2p1-2ubuntu3.2
Ubuntu 26.04 LTSopenssh-ssh1pkg:deb/ubuntu/openssh-ssh1?arch=source&distro=resoluteOther threatsAffected
  • =1:7.5p1-17
  • =1:7.5p1-18
Fixed in–
Ubuntu 25.10opensshpkg:deb/ubuntu/openssh?arch=source&distro=questingOther threatsAffected
  • <1:10.0p1-5ubuntu5.4
Fixed in
  • 1:10.0p1-5ubuntu5.4
Ubuntu 25.10openssh-ssh1pkg:deb/ubuntu/openssh-ssh1?arch=source&distro=questingOther threatsAffected
  • =1:7.5p1-17
Fixed in–
Ubuntu 24.04 LTSopensshpkg:deb/ubuntu/openssh?arch=source&distro=nobleOther threatsAffected
  • <1:9.6p1-3ubuntu13.16
Fixed in
  • 1:9.6p1-3ubuntu13.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until then, avoid using principals lists with Certificate Authorities that use comma characters in the authorized_keys configuration in affected versions.

Description

OpenSSH versions prior to 10.3 contain a vulnerability in the handling of the authorized_keys principals option. This issue arises in uncommon scenarios where a principals list is used together with a Certificate Authority that utilizes comma characters in a specific way. The vulnerability affects multiple Ubuntu releases and their Pro/FIPS variants. The CVSS vector indicates a network attack vector with high attack complexity and low privileges required, resulting in limited confidentiality and integrity impact without availability impact.

References

Community reviews

Loading reviews…