CVE-2026-35414: OpenBSD OpenSSH · Always-Incorrect Control Flow Implementation
Affects OpenBSD OpenSSHSource CVE Database V5
Not known to be exploited · CVSS 4.2 Medium : upgrade to 10.3 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade OpenBSD OpenSSH to 10.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenBSDOpenSSH | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should exercise caution when using principals lists combined with Certificate Authorities that include comma characters in authorized_keys configurations.
Description
CVE-2026-35414 is a medium severity vulnerability in OpenSSH versions prior to 10.3. It involves an always-incorrect control flow implementation (CWE-670) related to the mishandling of the authorized_keys principals option in uncommon scenarios where a principals list is combined with a Certificate Authority that uses comma characters. This flaw may lead to limited confidentiality and integrity impacts but does not affect availability.