CVE-2026-39850: yiisoft yii2 · Improper Input Validation
Affects yiisoft yii2Source CVE Database V5
Not known to be exploited · CVSS 7.4 High : upgrade to 2.0.55 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.55
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade yii2 and yiisoft/yii2 to 2.0.55.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| yiisoftyii2 | Affected
| Fixed in
|
Packagistyiisoft/yii2pkg:composer/yiisoft/yii2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Yii 2 version 2.0.55. Users should upgrade to version 2.0.55 or later to remediate this issue. Since this is not a cloud service, patching the affected software is required. Patch status is confirmed by the vendor's versioning information. No alternative mitigations are indicated.
Description
Yii 2 versions 2.0.54 and earlier contain a vulnerability in the core view rendering method View::renderPhpFile() that allows local file inclusion due to improper input validation. This occurs because the function uses extract($_params_, EXTR_OVERWRITE) before including the view file, enabling an attacker to overwrite the internal variable specifying the file to include via a specially crafted _file_ key in the parameters array. This flaw can lead to remote code execution if an attacker can write PHP files through another vulnerability, as well as information disclosure. The issue is fixed in version 2.0.55.