CVE-2023-45360: MediaWiki · Cross-site Scripting
Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium · fixed in 1.40.1 : update MediaWiki when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Affects
- MediaWiki before 1.35.12
- Patch
- Available – fixed in 1.40.1, 1.39.5, 1.35.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
- Upgrade MediaWiki installations to the latest patched versions: 1.35.12 or later, 1.39.5 or later, and 1.40.1 or later as applicable.
- Audit and sanitize all custom i18n message translations, especially those related to user notifications, to ensure no unsafe HTML or JavaScript is included.
- Implement Content Security Policy (CSP) headers to restrict script execution and reduce the impact of potential XSS attacks.
- Educate users about the risks of clicking on untrusted links or messages within MediaWiki environments.
- Monitor MediaWiki logs for unusual activity that could indicate exploitation attempts.
- If upgrading immediately is not feasible, consider disabling or restricting the use of the affected i18n messages temporarily.
- Regularly review and apply security advisories from the MediaWiki project to stay current on patches and mitigations.
Description
An issue was discovered in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. There is XSS in youhavenewmessagesmanyusers and youhavenewmessages i18n messages. This is related to MediaWiki:Youhavenewmessagesfromusers.
References
- phabricator.wikimedia.org/T340221 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/ (opens in a new tab)