CVE-2023-46942: Improper Authentication
Source CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 1.0.0 : patch affected systems soon.
Data as of 26 Oct 2026, 12:29 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n/a n/a | Affected
| Fixed in– |
AI-suggested
- Immediate upgrade to version 1.0.0-rc.8 or later of the @evershop/evershop package where the authentication issue is resolved.
- If upgrading is not immediately feasible, implement network-level access controls such as IP whitelisting or VPN restrictions to limit access to GraphQL endpoints.
- Introduce an authentication proxy or API gateway in front of the GraphQL endpoints to enforce authentication and authorization policies.
- Conduct a thorough audit of all GraphQL queries and mutations exposed by the application to ensure sensitive data is not accessible without proper authentication.
- Monitor logs for unusual access patterns or repeated unauthorized queries targeting GraphQL endpoints.
- Educate development teams on secure GraphQL API design, emphasizing the importance of authentication and authorization checks on all endpoints.
- Prepare incident response plans for potential data breaches, including notification procedures compliant with GDPR requirements.
Description
Lack of authentication in NPM's package @evershop/evershop before version 1.0.0-rc.8, allows remote attackers to obtain sensitive information via improper authorization in GraphQL endpoints.