Skip to main content
VulnerabilityPublished Updated

CVE-2023-50919: Improper Authentication

Source CVE Database V5

0

Public exploit available (Metasploit) · 47% EPSS · CVSS 9.8 Critical · fixed in 4.5.0 : patch affected systems as a priority.

Data as of 26 Oct 2026, 12:29 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
47.8% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
n/a n/aAffected
  • <4.5.0
Fixed in
  • 4.5.0

AI-suggested

To mitigate CVE-2023-50919, European organizations using GL.iNet devices should immediately upgrade affected devices to firmware version 4.5.0 or later, where the authentication bypass has been addressed. If immediate upgrade is not feasible, organizations should restrict management interface access to trusted internal networks only, using firewall rules or VLAN segmentation to prevent exposure to untrusted networks or the internet. Additionally, monitoring network traffic for unusual access patterns or unauthorized configuration changes can help detect exploitation attempts. Organizations should also consider disabling remote management features if not required. For environments with high security requirements, replacing vulnerable devices with alternatives from vendors with robust security track records may be warranted. Finally, maintaining an inventory of all GL.iNet devices and their firmware versions is critical for ensuring timely patch management and vulnerability remediation.

Description

An issue was discovered on GL.iNet devices before version 4.5.0. There is an NGINX authentication bypass via Lua string pattern matching. This affects A1300 4.4.6, AX1800 4.4.6, AXT1800 4.4.6, MT3000 4.4.6, MT2500 4.4.6, MT6000 4.5.0, MT1300 4.3.7, MT300N-V2 4.3.7, AR750S 4.3.7, AR750 4.3.7, AR300M 4.3.7, and B1300 4.3.7.

References

Community reviews

Loading reviews…