Skip to main content
CVE-2024-10909VulnerabilityPublished Updated

CVE-2024-10909: Pojo Forms (WordPress plugin) · Code Injection

Affects Pojo Forms (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.3 Medium · fixed in 1.4.8 : update Pojo Forms (WordPress plugin) when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
kingyes Pojo FormsAffected
  • =0
Fixed in–

AI-suggested

A partial fix was introduced in version 1.4.8 of the Pojo Forms plugin. Users should upgrade to version 1.4.8 or later to mitigate this vulnerability. Until patched, restrict Subscriber-level access or higher users from untrusted environments if possible.

Description

The The Pojo Forms plugin for WordPress is vulnerable to arbitrary shortcode execution via form_preview_shortcode AJAX action in all versions up to, and including, 1.4.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes. This was partially fixed in version 1.4.8.

References

Community reviews

Loading reviews…