Skip to main content
VulnerabilityPublished

CVE-2024-12139: WSO2 API Manager · Content Spoofing via Error Handling

Affects WSO2 API ManagerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium · fixed in 4.2.0.148 : update WSO2 API Manager when convenient.

Data as of 2 Nov 2026, 19:28 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (WSO2)CVSS 3.14.3
Patch
Available – fixed in 4.2.0.148, 4.1.0.210, 3.2.1.49 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.148
Fixed in
  • 4.2.0.148
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.210
Fixed in
  • 4.1.0.210
WSO2WSO2 API ManagerAffected
  • >=3.2.1 <3.2.1.49
Fixed in
  • 3.2.1.49
WSO2WSO2 Identity ServerAffected
  • >=6.0.0 <6.0.0.229
Fixed in
  • 6.0.0.229
WSO2WSO2 Identity ServerAffected
  • >=5.11.0 <5.11.0.385
Fixed in
  • 5.11.0.385
WSO2WSO2 Identity ServerAffected
  • >=5.10.0 <5.10.0.346
Fixed in
  • 5.10.0.346

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions addressing this vulnerability have been released for all affected versions of WSO2 API Manager. Users should upgrade to the respective fixed versions: 3.2.1.49, 4.1.0.210, 4.2.0.148, 5.10.0.346, 5.10.0.339, 5.11.0.385, or 6.0.0.229. Applying these official fixes is the recommended remediation. No additional vendor advisory indicates alternative mitigations or that no action is required.

Description

The error handling implementation fails to properly sanitize or validate user-supplied input within URL parameters under specific conditions. This allows end-users to manipulate the error messages that are displayed by the application. By exploiting this vulnerability, malicious actors can inject arbitrary content into error messages. This enables them to perform social engineering attacks, such as phishing or credential theft, by replacing legitimate error messages with malicious content, misleading users into compromising sensitive information or taking harmful actions.

References

Community reviews

Loading reviews…