CVE-2024-12419: WOW Styler for CF7 (WordPress plugin) · Code Injection
Affects WOW Styler for CF7 (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium · fixed in 1.7.0 : update WOW Styler for CF7 (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| tobias_conrad WOW Styler for CF7 – Visual Styler for Contact Form 7 Forms | Affected
| Fixed in– |
AI-suggested
Since the plugin is not a cloud service, remediation depends on vendor patch release or applying custom mitigations such as disabling or restricting the vulnerable functionality. The reflected XSS issue was fixed in version 1.7.0, but the shortcode execution flaw remains.
Description
The The Design for Contact Form 7 Style WordPress Plugin – CF7 WOW Styler plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.7.0. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. This functionality is also vulnerable to Reflected Cross-Site Scripting. Version 1.7.0 patched the Reflected XSS issue, however, the arbitrary shortcode execution issue remains.
References
- wordfence.com/threat-intel/vulnerabilities/id/5d78ea71-5886-488e-a660-0dc25129a8b6?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/cf7-styler/tags/1.6.9/admin/class-cf7-customizer-admin.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/cf7-styler/tags/1.6.9/admin/class-cf7-customizer-admin.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/cf7-styler/tags/1.6.9/admin/class-cf7-customizer-admin.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/cf7-styler/tags/1.7.1/admin/class-cf7-customizer-admin.php (opens in a new tab)