Skip to main content
VulnerabilityPublished Updated

CVE-2024-12635: WP Docs · SQL Injection

Affects WP DocsSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 2.2.0 : update WP Docs when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
fahadmahmood WP DocsAffected
  • =0
Fixed in–

AI-suggested

The vulnerability was partially patched in version 2.2.0 of the WP Docs plugin. However, no official full patch or update link is currently provided. Users should verify if a newer version beyond 2.2.0 is available that fully addresses the issue. Until a complete fix is confirmed, restrict plugin usage to trusted users and consider additional database query protections or monitoring for suspicious activity.

Description

The WP Docs plugin for WordPress is vulnerable to time-based SQL Injection via the 'dir_id' parameter in all versions up to, and including, 2.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. The vulnerability was partially patched in version 2.2.0.

References

Community reviews

Loading reviews…