CVE-2026-44209: masci banks · Template Injection
Affects masci banksSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.2 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade banks and masci/banks to 2.4.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mascibanks | Affected
| Fixed in
|
GitHubmasci/bankspkg:github/masci/banksOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in masci banks version 2.4.2. Users should upgrade to version 2.4.2 or later to remediate this vulnerability. The vendor advisory from Red Hat does not indicate any alternative mitigations or that no action is required. Therefore, upgrading is the recommended remediation.
Description
Banks generates meaningful LLM prompts using a template language that makes sense. Prior to 2.4.2, banks uses jinja2.Environment() (unsandboxed) to render prompt templates. Applications that pass user-supplied strings as the template argument to Prompt() are vulnerable to Server-Side Template Injection (SSTI), which can lead to Remote Code Execution (RCE) on the host system. This vulnerability is fixed in 2.4.2.
References
- github.com/masci/banks/security/advisories/GHSA-gphh-9q3h-jgpp (opens in a new tab)
- github.com/masci/banks/pull/74 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-44209 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2481713 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44209.json (opens in a new tab)