Skip to main content
VulnerabilityPublished Updated

CVE-2026-61536: masci banks · Code Injection

Affects masci banksSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.3 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade masci banks to 2.4.3.

Affected software

ProductAffectedFixed in
mascibanksAffected
  • <2.4.3
Fixed in
  • 2.4.3
PyPIbankspkg:pypi/banksOther threatsAffected
  • <2.4.3
Fixed in
  • 2.4.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in masci banks version 2.4.3. Users should upgrade to version 2.4.3 or later to remediate this vulnerability. No other mitigations are indicated or effective because the vulnerability involves unsafe dynamic imports without sanitization. Patch status is confirmed by the vendor advisory stating the issue is fixed in 2.4.3.

Description

CVE-2026-61536 is a high-severity code injection vulnerability in the masci banks product prior to version 2.4.3. It arises from unsafe dynamic import and attribute access of Python callables based on attacker-controlled input in Tool JSON objects within LLM prompt templates. This allows arbitrary code execution in the hosting process. The issue was fixed in version 2.4.3.

References

Community reviews

Loading reviews…