Skip to main content
CVE-2024-12915VulnerabilityPublished Updated

CVE-2024-12915: Devinim Software Library Software · XSS or 'Cross-site Scripting'

Affects Devinim Software Library SoftwareSource CVE Database V5

0

Not known to be exploited · CVSS 4.6 Medium : upgrade to 24.11.02 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 24.11.02
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Devinim Software Library Software to 24.11.02.

Affected software

ProductAffectedFixed in
Devinim Software Library SoftwareAffected
  • <24.11.02
Fixed in
  • 24.11.02

AI-suggested

If you cannot patch yet, users should consider applying input validation or output encoding as temporary mitigations if feasible.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Devinim Software Library Software allows Reflected XSS. This issue affects Library Software: before 24.11.02.

References

Community reviews

Loading reviews…