Skip to main content
VulnerabilityPublished Updated

CVE-2024-14031: YVES Sereal::Encoder · Dependency on Vulnerable Third-Party Component

Affects YVES Sereal::EncoderSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.1 High.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
YVESSereal::EncoderAffected
  • >=4.000 <=4.009_002
Fixed in–
GitHubSereal-Encoderpkg:github/Sereal-EncoderOther threatsAffected
  • >=4.000 <=4.009_002
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Consider avoiding use of affected versions or replacing the embedded Zstandard library with a fixed version (1.3.8 or later) if feasible.

Description

Sereal::Encoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library. Sereal::Encoder embeds a version of the Zstandard (zstd) library that is vulnerable to CVE-2019-11922. This is a race condition in the one-pass compression functions of Zstandard prior to version 1.3.8 could allow an attacker to write bytes out of bounds if an output buffer smaller than the recommended size was used.

References

Community reviews

Loading reviews…