Skip to main content
VulnerabilityPublished Updated

CVE-2024-21910: TinyMCE · Cross-site Scripting

Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium · fixed in 5.10.0 : update affected systems when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.10.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

A fix is available in TinyMCE version 5.10.0 and later. Users should upgrade to version 5.10.0 or newer to remediate this vulnerability. Since this is not a cloud service, remediation depends on applying the update to affected deployments. Patch status is confirmed by the version information provided.

Description

TinyMCE versions before 5.10.0 are affected by a cross-site scripting vulnerability. A remote and unauthenticated attacker could introduce crafted image or link URLs that would result in the execution of arbitrary JavaScript in an editing user's browser.

References

Community reviews

Loading reviews…